Androidプロジェクトコンパイル時に "Android requires compiler compliance level 5.0 or 6.0. Found ’1.7′ instead. Please use Android Tools > Fix Project Properties." エラーが発生しビルドできない

このページのタグ:[Android]
Androidプロジェクトコンパイル時に "Android requires compiler compliance level 5.0 or 6.0. Found ’1.7′ instead. Please use Android Tools > Fix Project Properties."エラーが発生し、プロジェクトのビルドに失敗することがあります。

解決方法

Eclipseの[Window]メニューの[Preferences]メニューを選択します。


[Preferences]ダイアログが表示されます。左側のメニューの[Java]メニューの[Compiler]サブメニューをクリックして選択します。右側の[Compiler]画面の[Compiler compliance level:]の欄が"1.7"になっています。


[Compiler compliance level:]のコンボボックスを選択し、"1.6"に変更します。


変更後、ビルドを実行すると"Android requires compiler compliance level 5.0 or 6.0. Found ’1.7′ instead. Please use Android Tools > Fix Project Properties."エラーが発生せずビルドできます。

プライバシー    iPentecについて
iPentec all rights reserverd. (ISDC)